[Beta Release] RVM Integrator 1.6.1 Beta 2.1


The RVM Integrator was created by picking the mind of RyanVM of msfn.org. It allows you to actually slipstream windows hotfixes and third party software directly into a windows install disk. This is unlike any other software out there that claims to do this. It allows advanced users to create simple UpdatePack/Addons for others to use to slipstream things to their disks.

Postby OnePiece » Fri May 15, 2009 4:25 pm

Hello Siginet, I think not, because if I am not mistaken RVMi puts all entries.ini in a section z_datastore (for example in [Dosnet_Files]), and the section [Dosnet_Files] does not accept more than 560 line, so in any way that months the line is only one entries.ini or 2 3 4 that does not write more than 560 line.

or decided for now to make a normal entires.ini, after making an addon for repair RVMi be integrated later, addon repair take almost 20-30 seconds to integrated, so no problem for those who use the RVMi.

Ciao
User avatar
OnePiece
Junior Member

Posts: 8
Users Information
Location: Ballkan
Joined: Fri Nov 02, 2007 2:54 am

Postby Siginet » Fri May 15, 2009 4:46 pm

OK I think you may be right.

So I think the best plan of action would be if the integrator would recognize when too much information is placed into the z_datastore.ini section. Once there is about 500 lines or so many bytes of info in any section it automatically creates a new section with the same name plus "_01" at the end. Or "_02" "_03" and so on.

For instance:
[Dosnet_Files]

[Dosnet_Files_01]

[Dosnet_Files_02]

[Dosnet_Files_03]
Image
Windows XP PowerPacker Reviewed in PC-Quest & PC Utilities magazines!
RVM Integrator Reviewed in CPU magazine and Maximum PC!
--Siginet--
User avatar
Siginet
Senior Member

Posts: 1445
Users Information
Joined: Sat May 06, 2006 3:24 pm

Postby OnePiece » Fri May 15, 2009 5:29 pm

That should be OK, the [Txtsetup_Files] writes more or less 1100 line, so also add a [Txtsetup_Files_01]

Ciao.
User avatar
OnePiece
Junior Member

Posts: 8
Users Information
Location: Ballkan
Joined: Fri Nov 02, 2007 2:54 am

Postby beats » Sat May 16, 2009 12:39 pm

Hello guys,

Thought I should drop by to thank you all for this nifty and wonderful tool. ;)
beats
Junior Member

Posts: 6
Users Information
Joined: Sat May 16, 2009 12:34 pm

Postby bhishmar » Wed May 27, 2009 10:28 pm

@yumeyao, siginet, 5eraph, code65k, ... & all other admin experts.

Thanks for this excellent piece of software, and the continuing efforts to improve it, in terms of features, performance & reliability.

I have a request from a simple Software Configuration Control point of view.

Please put release-dates on each of the software-versions in the 1st post. If not, then atleast put a last-update date on the 1st post header-line.

In the absence of these, it is very difficult to keep track of the changes, WHEN it is made, and WHETHER a new release has appeared after the last visit of the user, at least in a quick-look.

Moreover, if anybody wants to keep track of the observations & feedback presented here w.r.to a particular version, then it is a hopeless excercize, especially for an infrequent visitor. A release date with each version, goes a longway in addressing these shortcomings.

Thanks & regards
bhishmar
Junior Member

Posts: 26
Users Information
Joined: Thu Jan 04, 2007 2:06 pm

Postby OuT » Fri May 29, 2009 6:14 pm

with 1.6.1 beta2.1, when selecting "file > optimize system files now", error box appears...
title : AutoIt Error
message :
Line -1:
Error : Variable used without being declared.
Last edited by OuT on Mon Jul 27, 2015 10:10 pm, edited 1 time in total.
OuT
Junior Member

Posts: 3
Users Information
Joined: Fri May 02, 2008 6:32 pm

Postby mr_smartepants » Sat May 30, 2009 1:19 am

OuT wrote:with 1.6.1 beta2.1, when selecting "file > optimize system files now", error box appears...
title : AutoIt Error
message :
Line -1:
Error : Variable used without being declared.


Already reported on post #36. (one page previous) :)
Not all heroes wear capes, some wear Kevlar! OEMSCAN pre-activation addon for OEM XP & 2003
mr_smartepants
Senior Member

Posts: 536
Users Information
Joined: Sat Feb 03, 2007 2:06 am

Postby 5eraph » Sat May 30, 2009 6:59 am

A patch has been written to fix that problem and another. It will be incorporated into the next release. :)
5eraph
Senior Member

Posts: 119
Users Information
Age: 44
Location: Riverview, MI USA
Joined: Thu May 18, 2006 12:51 pm

Postby yumeyao » Sat May 30, 2009 9:27 pm

@mr_smartepants & OuT:
I have detected this issue and locally fixed it. and i'll take a look at 5eraph's patch after i finish my exams.

@5eraph:
thanks for the patch and your help.

@all devs:
The current source on my hand is really untidy so I don't want to comment all changes i made nor upload it. If you are interested and willing to read the untidy one, sure you can email me and i'll send you the source.[color="Silver"]

---------- Post added at 10:27 AM ---------- Previous post was at 10:24 AM ----------

[/color]Additionally:
Is my IP banned by the forum? or the forum is banned by GFW? I have problems accessing the forum. Now i'm visiting via a proxy. Can anybody helps?
yumeyao
Member

Posts: 69
Users Information
Joined: Fri Jun 15, 2007 7:45 am

Postby 5eraph » Sun May 31, 2009 12:50 pm

Your user name is obviously not banned, YumeYao. I'm not aware of any way to ban IP addresses in vBulletin. At least, I can't find the controls to do so, or the controls to lift such a ban if it has occurred.
5eraph
Senior Member

Posts: 119
Users Information
Age: 44
Location: Riverview, MI USA
Joined: Thu May 18, 2006 12:51 pm

PreviousNext

Return to RyanVM Integrator

Who is online

Users browsing this forum: No registered users and 4 guests