[Beta Release] RVM Integrator 1.6.1 Beta 2.1


The RVM Integrator was created by picking the mind of RyanVM of msfn.org. It allows you to actually slipstream windows hotfixes and third party software directly into a windows install disk. This is unlike any other software out there that claims to do this. It allows advanced users to create simple UpdatePack/Addons for others to use to slipstream things to their disks.

Postby ianymaty » Tue Mar 31, 2009 3:11 pm

Updated Romanian language file. As usual in both version with and without diacritics.
You do not have the required permissions to view the files attached to this post.
ianymaty
Junior Member

Posts: 5
Users Information
Age: 43
Location: ROMANIA, Timisoara
Joined: Sun Feb 17, 2008 8:08 am

Postby wazer » Tue Mar 31, 2009 4:30 pm

yumeyao wrote:I mean what OS, and what language do you use.

Additionally, I hope you can list a full list of all your shell extensions in use, they might damage an app if some of them tried to consume some resources when context menu showed.


XP Pro sp3 corp from my military "Danish Install"

Im using kels uber addon pack and hes cpl pack as shell extension with the power tweaks when you right click.

Other sell extension: Winrar,7z,universal extractor.

Edit: I can try remove some of the tools when i got the time and see if it helps :)
wazer
Junior Member

Posts: 9
Users Information
Joined: Tue Aug 07, 2007 11:36 am

Postby Siginet » Wed Apr 01, 2009 12:42 pm

wazer wrote:XP Pro sp3 corp from my military "Danish Install"

Im using kels uber addon pack and hes cpl pack as shell extension with the power tweaks when you right click.

Other sell extension: Winrar,7z,universal extractor.

Edit: I can try remove some of the tools when i got the time and see if it helps :)


More then likley the shell pack is causing the problem. I am using Windows XP Fully updated with Ryans UP and I am not having any right click issue in the integrator.
Image
Windows XP PowerPacker Reviewed in PC-Quest & PC Utilities magazines!
RVM Integrator Reviewed in CPU magazine and Maximum PC!
--Siginet--
User avatar
Siginet
Senior Member

Posts: 1445
Users Information
Joined: Sat May 06, 2006 3:24 pm

Postby Raoul90 » Wed Apr 01, 2009 4:14 pm

yumeyao wrote:two points:
1. does it worked before if you integrated it with RVM 1.6 Final? or other version?

2. regarding my note on MCE source: it has to be a true MCE source, not any XP2MCE conversation addon.


Its not caused by the integrator.
Havent found the problem yet tho.
Tomorrow I will try the MCE addon of Sick only @ SP3 source (WMP/IE6) so not other integrations (MCE addon of Sick must be integrated with nLite), only the MCE, if it doesnt work by then, the MCE addon is the problem.
Raoul90
Junior Member

Posts: 7
Users Information
Joined: Wed Dec 17, 2008 12:43 pm

Postby crashfly » Thu Apr 16, 2009 1:19 am

Hmmm ... seems to be another "bug" with the latest RVM Integrator (beta 2.1). Using redxii's latest update pack, I have integrated it into my "source" and come to find out there is a problem. sp3.cab is still referenced in the TXTSETUP.SIF file, but it is not present after I integrate the update pack.

The option to "Optimize System Files" was *not* turned on when the update was run.

Edit: Forgot to mention, there is a problem when the setup is run, as it wants the SP3.cab when there is not one there.[color="Silver"]

---------- Post added at 11:52 PM ---------- Previous post was at 10:50 PM ----------

[/color]SP3.cab is still missing (plus many more) when "Optimize System Files" is selected.

I am definitely finding that entries are not being removed from TXTSETUP.SIF *or* files are being removed causing 'file missing' errors.

Each time, I start out with a fresh XP SP3 source, and then perform *just* the update with RVM Integrator. Seems as if these recent optimizations have caused some problems.[color="Silver"]

---------- Post added at 01:06 AM ---------- Previous post was Yesterday at 11:52 PM ----------

[/color]How foobarish of me. I figured out what it was that was going wrong. Does not appear to be the Integrator at this time. It was a mistake that I was making.

Testing the snafu I made now. If it works, then I need to re-evaluate my procedure for updating my source. Seems I accidentally skipped a step.[color="Silver"]

---------- Post added at 01:19 AM ---------- Previous post was at 01:06 AM ----------

[/color]Seems the bug was all mine. Problem resolved. Ignore the above listed errors.
A mind is like a parachute, it only functions when it is open.
--Anonymous

(It is a crying shame that too many fall apart when opening up.)
crashfly

Posts: 66
Users Information
Age: 42
Location: Arkansas, USA
Joined: Mon Aug 04, 2008 12:19 pm

Postby 5eraph » Thu Apr 16, 2009 7:15 pm

I'm sorry to hear you were having problems. But I'm glad you figured them out.

I've had the occasional brain fart. If I can average less than two a day then I'm doing well. :)
_________________

"Measure twice, cut once."
5eraph
Senior Member

Posts: 119
Users Information
Age: 44
Location: Riverview, MI USA
Joined: Thu May 18, 2006 12:51 pm

Postby crashfly » Thu Apr 16, 2009 8:27 pm

Lol. Thanks 5eraph for that response. I was "having one of those days" until I saw that. At least my brain 'fart' does not kill the brain. Then I might have to be listed as brain dead.
A mind is like a parachute, it only functions when it is open.
--Anonymous

(It is a crying shame that too many fall apart when opening up.)
crashfly

Posts: 66
Users Information
Age: 42
Location: Arkansas, USA
Joined: Mon Aug 04, 2008 12:19 pm

Postby ChiefZeke » Fri Apr 17, 2009 5:46 pm

Just thought I'd mention that I just ran beta 2.1, RED_XP_SP3_UpdatePack_04.09-01.7z, many other addons, DriverPacks, made ISO and everything went great.

Looks likje a great job has been done by all those involved. :)
ChiefZeke
Senior Member

Posts: 290
Users Information
Age: 77
Location: Victorville, California
Joined: Fri Mar 30, 2007 5:33 pm

Postby mr_smartepants » Mon Apr 27, 2009 4:30 pm

I don't know if this is a bug or just a typo. But I've been playing around with XP Pro x64 and noticed something in the logs.
2009-04-27_22.17.07
Log Startup @ 22:17:07 local time, on April 27, 2009.

Running OS: WIN_VISTA Service Pack 1 X64
RVMIntegrator v1.6.1 beta2.1

"C:\AutoImage\RVM\1.6\RVM_Integrator_1.6.1b2.1.exe"

22:18:04 - English - Windows XP Professional x64 - OEM SP1 Found
22:18:04 -
22:18:04 - Source Location = C:\Users\Erik\Desktop\XP64
22:18:04 - Destination Path = C:\Users\Erik\Desktop\XP64
22:18:04 - Destination Size = 141.87 GB
22:18:04 - Working Directory = C:\Users\Erik\Desktop\XP64\AMD64
22:18:04 - Temp Directory = C:\Users\Erik\Desktop\XP64\AMD64\rvmtemp
22:18:04 -
22:18:04 - Starting Integration
22:18:04 -
22:18:04 - Checking Destination For OS Type.
22:18:05 - English - Windows XP Professional x64 - OEM SP1 Found
22:18:05 -
22:18:05 - Extracting OEMSCAN_1.4.1_MR_SMARTEPANTS_ADDON_MULTIOEM_1.8.10.7z
22:18:44 - MD5 Hash = 0a56482e661fa7d26731175e7eef00ec
22:18:44 - Clearing any Read Only Attributes.
22:20:06 -
22:20:06 - Gathering temp files
22:20:06 - Integrating Windows XP Professional Files.
22:20:06 - 0 Files Moved in 0 Seconds
22:20:06 - Processing new .CAT files found in SVCPACK
22:20:06 -
22:20:06 - Shifting Stuff Around
22:20:07 - 266 Files Moved in 0 Seconds
22:20:07 - Analyzing 1 Entry Files
22:20:07 - Processing OEMSCAN 1.4.1 Addon for multi-system installs v1.8.10/mr_smartepants Build Date: 2009/04/28
22:20:07 - Gathering [DirMove] Entries
22:20:07 -
22:20:07 - Preparing System Files...
22:20:07 - sysoc.inf
22:20:07 - svcpack.inf
22:20:07 - dosnet.inf
22:20:07 - txtsetup.sif
22:20:14 -
22:20:14 - Processing Sysoc.inf
22:20:14 - Processing svcpack.inf
22:20:14 - Processing dosnet.inf
22:20:15 - Processing txtsetup.sif
22:20:17 -
22:20:17 -
22:20:17 - Processing [EditFile]
22:20:18 -
22:20:18 - Moving Files Found In OEMSCAN 1.4.1 Addon for multi-system installs
22:20:18 - Moving Directories
22:20:24 - Entire .ini Processing Completed in 17 Seconds
22:20:24 -
22:20:24 - Compressing and Moving Edited Files
22:20:25 -
22:20:25 - Optimizing System Files.
22:20:25 - Combining dosnet.inf - [Files]
22:20:26 - Optimizing dosnet.inf - [Files]
22:20:28 - Combining dosnet.inf - [FloppyFiles.0]
22:20:28 - Optimizing dosnet.inf - [FloppyFiles.0]
22:20:28 - Combining dosnet.inf - [FloppyFiles.1]
22:20:29 - Optimizing dosnet.inf - [FloppyFiles.1]
22:20:29 - Combining dosnet.inf - [FloppyFiles.2]
22:20:29 - Optimizing dosnet.inf - [FloppyFiles.2]
22:20:30 - Combining dosnet.inf - [FloppyFiles.3]
22:20:30 - Optimizing dosnet.inf - [FloppyFiles.3]
22:20:30 - Combining dosnet.inf - [FloppyFiles.x]
22:20:30 - Optimizing dosnet.inf - [FloppyFiles.x]
22:20:31 - Combining txtsetup.sif - [SourceDisksFiles]
22:20:37 - Optimizing txtsetup.sif - [SourceDisksFiles]
22:20:38 - Combining txtsetup.sif - [SourceDisksFiles.ia64]
22:20:39 - Optimizing txtsetup.sif - [SourceDisksFiles.ia64]
22:20:40 - Combining txtsetup.sif - [SourceDisksFiles.amd64]
22:20:41 - Optimizing txtsetup.sif - [SourceDisksFiles.amd64]
22:20:41 - Combining txtsetup.sif - [SourceDisksFiles.x86]
22:20:42 - Optimizing txtsetup.sif - [SourceDisksFiles.x86]
22:20:46 - Optimizing txtsetup.sif - [WinntDirectories]
22:20:46 - Optimizing txtsetup.sif - [FileFlags]
22:20:47 -
22:20:47 - Scanning I386 for other files to compress...
22:20:51 - Compressing Files I386...

22:21:47 - Compressing Files DRW...
22:21:49 - Compressing Files WIN9XMIG...
22:21:51 - Optimizing System Files Finished In: 85 Seconds.
22:21:51 -
22:21:51 - Cleaning Up.
22:21:51 - Integration Completed.
22:21:51 - Total Integration Time = 226 Seconds
22:21:51 - ==================================================================================
22:21:51 -


Why is RVMI scanning \I386 for files to compress when this is a x64 source and it should be scanning \AMD64?
Or is it just a typo?
Not all heroes wear capes, some wear Kevlar! OEMSCAN pre-activation addon for OEM XP & 2003
mr_smartepants
Senior Member

Posts: 536
Users Information
Joined: Sat Feb 03, 2007 2:06 am

Postby 5eraph » Tue Apr 28, 2009 12:06 am

mr_smartepants wrote:
Code: Select all
[color=red]22:20:47  -   Scanning I386 for other files to compress...[/color]

This line is hard-coded into the optimization routine. It no longer accurately reflects the directory being scanned. This should be easy to correct.

mr_smartepants wrote:
Code: Select all
[color=red]22:20:51  -       Compressing Files I386...[/color]

This log statement is proper and accurate. But the lack of a corresponding AMD64 statement does indicate that the optimization process is incomplete for architectures other than x86. This may take more effort to fix.

Thanks for bringing it to our attention. :)
5eraph
Senior Member

Posts: 119
Users Information
Age: 44
Location: Riverview, MI USA
Joined: Thu May 18, 2006 12:51 pm

PreviousNext

Return to RyanVM Integrator

Who is online

Users browsing this forum: No registered users and 2 guests

cron