Burning RVMi *ISO files produces rvmintegrator.img file. Only one with this error??


The RVM Integrator was created by picking the mind of RyanVM of msfn.org. It allows you to actually slipstream windows hotfixes and third party software directly into a windows install disk. This is unlike any other software out there that claims to do this. It allows advanced users to create simple UpdatePack/Addons for others to use to slipstream things to their disks.

Burning RVMi *ISO files produces rvmintegrator.img file. Only one with this error??

Postby CHL2012 » Sat Mar 31, 2012 4:51 am

Until recently (about the last week or so), when I burned the ISO file produced by RVMi, I got the desired ISO file. But more recently, when I burn the so-called ISO file, I got the same rvmintegrator.img file -- at least the title was the same, but I have no idea if the file burned was the same each time.

When I started getting these IMG files, I looked for ways to convert IMG files to ISO files. I tried a few codes without noticeable results. Some produced errors in attempted conversion, and one even produced an error in installation. I tried to remove all codes I tried, but parts may be floating around, as I could not cleanly remove all parts of all the codes. So maybe, if no one else has seen this problem, maybe its only my problem/error.

As a brief test, I went back to some ISO files older than one week, and reburned a couple of files. All such tests reproduced the same ISO disk as before. So at least the problem seems recent.

Comments/suggestions requested.
CHL2012
Member

Posts: 31
Users Information
Joined: Tue Mar 06, 2012 4:46 pm

Postby CHL2012 » Sun Apr 01, 2012 6:45 am

I tried two (2) times tto post additional data about tests run after the original post. Each time the posts were somrhow lost and never posted.

If someone is really interested, I will try one more time, and if lost somewhere in the Forum mechanics, I will not post details again, wasting time.

So here goes ONE more time.
CHL2012
Member

Posts: 31
Users Information
Joined: Tue Mar 06, 2012 4:46 pm

Postby CHL2012 » Sun Apr 01, 2012 12:19 pm

I am having problems reconstructing some old and recent data. When I get some data/answers, I will Post back comments.

Sorry for this inconvenience.
CHL2012
Member

Posts: 31
Users Information
Joined: Tue Mar 06, 2012 4:46 pm

Postby CHL2012 » Mon Apr 02, 2012 4:15 am

One problem at a time.

The first is happening frequently now. In the old days -- about 2 weeks ago -- It took about 1 minute to Make ISO file with 1.6. Now it can take about 1 hour to Make ISO with Release 1.6. See the following:

2012-04-01_17.52.01
Log Startup @ 17:52:01 local time, on April 01, 2012.

Running OS: WIN_XP Service Pack 3 X86
RVMIntegrator v1.6

"C:\Documents and Settings\Administrator\Desktop\RVM_Integrator_1.6.exe"

17:52:01 - English - Windows XP Professional x86 - Retail SP3 Found
17:55:57 -
17:55:57 - Creating ISO
17:55:57 - Command Line = C:\WINDOWS\system32\cmd.exe /c C:\WINDOWS\System32\rvmisofs.exe -joliet-long -iso-level 2 -N -d -relaxed-filenames -duplicates-once -D -boot-load-seg 0x7C0 -boot-load-size 4 -o "C:\Win XP For nLite\TEST2_Orig.iso" -b rvmintegrator.img -hide rvmintegrator.img -hide boot.catalog -J -hide-joliet xpboot.img -hide-joliet boot.catalog -no-emul-boot -volid "RVMi" -sysid "Win32" "C:\Win XP For nLite\TEST2_Orig"
17:55:57 - Using Internal mkisofs 2.01-bootcd.ru (i686-pc-mingw32)
19:09:16 - Total translation table size: 2048
19:09:16 - ISO Complete

==================================

Began 17:56 and end 19:06. All to Make ISO. The file was just less than 700 MB.

From what you see in the last part of the Log, is there any reason that it should take about 1 hour to make the ISO. BTW, the ISO file also had a small IMG file, and some of the usual files/folders are not in the ISO file.

Anxious to find an answer to these problems.
CHL2012
Member

Posts: 31
Users Information
Joined: Tue Mar 06, 2012 4:46 pm

Postby ChiefZeke » Mon Apr 02, 2012 12:26 pm

I believe I told you in an earlier posting to use this version: RVM_Integrator_1.6.1b2.1.exe of the Integrator - a download link is available on the first page.

I just checked log files for my five previous completions using the RyanVMi and found no instance of any excessive time - so it could be the version of the Integrator you are using or some other issue at your end. If you continue to use the older version of the integrator you're on your own as far as I'm concerned.
ChiefZeke
Senior Member

Posts: 290
Users Information
Age: 75
Location: Victorville, California
Joined: Fri Mar 30, 2007 2:33 pm

Postby CHL2012 » Tue Apr 03, 2012 3:19 am

It seems it is always thought to be a problem on my end.

If one hour to create the ISO is accurate (see Log data), then why doesn't someone on that end admit there is a problem with the Released one?

I will run the same case with your Beta version and let you know what I find.

Are Users not to use the Released version and just use the Beta version?

We also still have the matter of why is rvmintegrator.img still coming up in the ISO file?
CHL2012
Member

Posts: 31
Users Information
Joined: Tue Mar 06, 2012 4:46 pm

Postby CHL2012 » Tue Apr 03, 2012 6:42 am

Here is the last part of the Log file for the case run on the Beta 2.1 Release

================================

07:47:38 - Total Integration Time = 1143 Seconds
07:47:38 -

============================================

======================================
07:47:38 -
07:52:38 -
07:52:38 - Creating ISO
07:52:38 - Command Line =

C:\WINDOWS\system32\cmd.exe /c

C:\WINDOWS\System32\rvmisofs.exe -joliet-long

-iso-level 2 -N -d -relaxed-filenames -duplicates-once

-D -boot-load-seg 0x7C0 -boot-load-size 4 -o "C:\Win

XP For nLite\TEST2_Beta_iso\TEST2_Beta.iso" -b

rvmintegrator.img -hide rvmintegrator.img -hide

boot.catalog -J -hide-joliet xpboot.img -hide-joliet

boot.catalog -no-emul-boot -volid "RVMi" -sysid

"Win32" "C:\Win XP For nLite\TEST2_Beta"
07:52:38 - Using Internal mkisofs 2.01-bootcd.ru

(i686-pc-mingw32)
08:53:06 - Total translation table size: 2048
08:53:07 - ISO Complete

=======================

1 hr and 1 sec from the Log to Make the ISO file. I will look at the ISO now and let you know the results.[color="Silver"]

---------- Post added at 10:42 AM ---------- Previous post was at 09:23 AM ----------

[/color]I looked at the files in IsoBuster, and the two files/folders list from both 1.6.1 and 1.6.1 Beta 2.1 are identical as far as I can tell without listing and comparison of the IsoBuster lists.

Each "ISO" output file had the famous rvmintegrator.img file included. It is only 2048 bytes, but why is it there?

I looked at the ISO file sizes produced by both versions of the code, and they were identical size of 673,904,640 byte.

Except for the rvmintegrator.img file and one hour to Make ISO file, things look pretty normal.

I plan to burn ISO CDs of the two versions and run them thru VirtualBox and see if there are any problems and/or differences. Since the IsoBuster file lists are identical, I will start with your Beta 2.1 disk.

Do you see any "problems on my end to explain the identical ISO files," since I seem to be the cause of all problems with RVM codes?

As I said, I plan to go forward with the VirtualBox test of your Beta 2.1 code output, unless you have a different, viz., better idea.
CHL2012
Member

Posts: 31
Users Information
Joined: Tue Mar 06, 2012 4:46 pm

Postby CHL2012 » Tue Apr 03, 2012 9:40 am

I am running Beta 2.1 ISO CD on VM VirtualBox now. I takes the same amount of time to load the VB as it does to install on real computer -- about an hour. I had one flagged error; the installation on VB could not find one file: clock.??? Otherwise a clean and uneventful installation of Windows XP with IE8.

I must make/find more space on C:\ or some other drive to continue the VB testing of RVM software. So I have some work to do on my computer.

Just wanted to let you know the Installation from the ISO CD went well.
CHL2012
Member

Posts: 31
Users Information
Joined: Tue Mar 06, 2012 4:46 pm

Postby ChiefZeke » Tue Apr 03, 2012 11:59 am

For all practical purposes the beta version is the last/final/best version of the Integrator to use. It's been in use for so long by so many people, with successful results, I doubt the author will ever, finally, make it a 'final' version.

Below are copies from the last three times I used the integrator - notice the ISO completion time is in seconds.

19:50:59 - Creating ISO
19:50:59 - Command Line = D:\Windows\Take Command\TCC.exe /c D:\WINDOWS\System32\rvmisofs.exe -joliet-long -iso-level 2 -N -d -relaxed-filenames -duplicates-once -D -boot-load-seg 0x7C0 -boot-load-size 4 -o "G:\RyanVM\XPPro#2ISO\XPPro#2SP3WMP11Integ.iso" -b rvmintegrator.img -hide rvmintegrator.img -hide boot.catalog -J -hide-joliet xpboot.img -hide-joliet boot.catalog -no-emul-boot -volid "XPProSP3WMP11Integ" -sysid "Win32" "G:\RyanVM\XPPro#2Integrated"
19:50:59 - Using Internal mkisofs 2.01-bootcd.ru (i686-pc-mingw32)
19:51:37 - ISO Complete


14:29:03 - Creating ISO
14:29:03 - Command Line = D:\Windows\Take Command\TCC.exe /c D:\WINDOWS\System32\rvmisofs.exe -joliet-long -iso-level 2 -N -d -relaxed-filenames -duplicates-once -D -boot-load-seg 0x7C0 -boot-load-size 4 -o "G:\RyanVM\XPPro#2ISO\XPPro#2SP3WMP11Integ.iso" -b rvmintegrator.img -hide rvmintegrator.img -hide boot.catalog -J -hide-joliet xpboot.img -hide-joliet boot.catalog -no-emul-boot -volid "XPProSP3WMP11Integ" -sysid "Win32" "G:\RyanVM\XPPro#2Integrated"
14:29:03 - Using Internal mkisofs 2.01-bootcd.ru (i686-pc-mingw32)
14:29:24 - ISO Complete

14:25:00 - Creating ISO
14:25:00 - Command Line = D:\Windows\Take Command\TCC.exe /c D:\WINDOWS\System32\rvmisofs.exe -joliet-long -iso-level 2 -N -d -relaxed-filenames -duplicates-once -D -boot-load-seg 0x7C0 -boot-load-size 4 -o "G:\RyanVM\XPPro#1ISO\XPPro#1SP3WMP11DPavInteg.iso" -b rvmintegrator.img -hide rvmintegrator.img -hide boot.catalog -J -hide-joliet xpboot.img -hide-joliet boot.catalog -no-emul-boot -volid "XPProSP3WMP11DPavInteg" -sysid "Win32" "G:\RyanVM\XPPro#1Integrated"
14:25:00 - Using Internal mkisofs 2.01-bootcd.ru (i686-pc-mingw32)
14:25:33 - ISO Complete


Why is nLite being invoked? Most people would not recommend combining the two integrators.

Go here for much more information/comments/etc about the Integrator: http://www.ryanvm.net/forum/

One more item:

Download Process Explorer from Sysinternals: http://technet.microsoft.com/en-us/sysinternals/default.aspx and have it open when you start things - watch it and see if you notice anything that appears to be out of the ordinary.
ChiefZeke
Senior Member

Posts: 290
Users Information
Age: 75
Location: Victorville, California
Joined: Fri Mar 30, 2007 2:33 pm

Postby CHL2012 » Wed Apr 04, 2012 7:05 am

You have made the negative comment about nLite before. I started using it before I knew of RVM, and have not used it for some time. Your reference to nLite must be from a directory heading in the code which HAS NOTHING to do with mixing codes, data or output.

I will checkout Sysinternals when I get my system disk upgraded. Soon I hope.

I found some earlier Make ISOs to be about 1 minute also, but they were about 300 MB and not near 700 MB. Still, one hour to make an ISO file seems extreme. Would you not agree??
CHL2012
Member

Posts: 31
Users Information
Joined: Tue Mar 06, 2012 4:46 pm

Next

Return to RyanVM Integrator

Who is online

Users browsing this forum: No registered users and 1 guest

cron