OEMSCAN_ADDON_MULTIOEM v1.61


OEM A.C.T. (OEM Activation Control Technology)
This is a method that allows you to create a Windows XP Setup disk that has Multiple Manufacturer oembios.* files on it. During installation a script is run that determines what oembios.* files are needed for the system so that you will have a pre-activated install. This will help lessen the times that you need to call Microsoft for activation. :D

Postby mr_smartepants » Wed Jan 21, 2009 8:41 am

Yeah, right now I have it as a single addon. If the "Logos" subfolders (they're labeled exactly as oemscan detects them) are empty, you'll get some "file not found" errors but it won't adversely affect anything.
The problem (and I'll need feedback to fix this) is that the folders need to be named EXACTLY as oemscan detects the system. I've preloaded the addon with the folders as they're listed on oembios.net but only field-tests will prove it works. I'm polishing it up and removing all my testing comments out of the code, then I'll upload tonight.
Not all heroes wear capes, some wear Kevlar! OEMSCAN pre-activation addon for OEM XP & 2003
mr_smartepants
Senior Member

Posts: 536
Users Information
Joined: Fri Feb 02, 2007 11:06 pm

Postby gospeed.racer » Wed Jan 21, 2009 8:46 am

I would just tell everyone to put in a generic logo (or place in a logo of our own as a placeholder) so the error never occurs. Those that want to change it can, and others can leave it or blank it out knowing there will be an error.

Sounds awesome!
gospeed.racer
Senior Member

Posts: 102
Users Information
Joined: Fri Feb 02, 2007 10:01 pm

Postby mr_smartepants » Wed Jan 21, 2009 10:51 am

For debugging purposes, does anyone know how to dump the contents of the command window to a .txt file? I can do it with a vbs script, but I want a command I can put at the beginning of the .cmd file to output the whole session to .txt for problem solving here.

Almost done with the addon...

@Siginet, can you email me with acct info to upload to your addon server? So I don't have to attach it to a post. :)
Not all heroes wear capes, some wear Kevlar! OEMSCAN pre-activation addon for OEM XP & 2003
mr_smartepants
Senior Member

Posts: 536
Users Information
Joined: Fri Feb 02, 2007 11:06 pm

Postby Siginet » Wed Jan 21, 2009 11:37 am

PM sent. ;)
Image
Windows XP PowerPacker Reviewed in PC-Quest & PC Utilities magazines!
RVM Integrator Reviewed in CPU magazine and Maximum PC!
--Siginet--
User avatar
Siginet
Senior Member

Posts: 1448
Users Information
Joined: Sat May 06, 2006 12:24 pm

Postby mr_smartepants » Wed Jan 21, 2009 2:00 pm

New thread posted: http://siginetsoftware.com/forum/showthread.php?p=5571
I'll maintain this thread here until it's no longer useful.
Not all heroes wear capes, some wear Kevlar! OEMSCAN pre-activation addon for OEM XP & 2003
mr_smartepants
Senior Member

Posts: 536
Users Information
Joined: Fri Feb 02, 2007 11:06 pm

mabye a dumb question

Postby godofmonkeys » Wed Jan 28, 2009 4:04 am

removed
godofmonkeys
Junior Member

Posts: 4
Users Information
Joined: Thu Jan 22, 2009 2:33 pm

Postby RudeBoySes » Thu Apr 01, 2010 8:20 pm

" wrote:I've preloaded the addon with the folders as they're listed on oembios.net


Hi [color="YellowGreen"]Mr_Smartepants[/color]..
i hope you can guide me into the right path ...
i have compiled approximately 5 or 6 ISOs already ..
tested all 5 or 6 on VMware .. all stating the Key is incorrect mid-way during install.. and when i try to enter the OEM-SLP key.. it refuses it .. leading me to believe OEMSCAN is not functioning/installing the OEMBIOS files ..

Now.. when i install a single OEM Disc on Vmware .. it works .. i have HP-COMPAQ BIOS ..

[color="Red"]F.Y.I[/color]
I have set up 89 different OEM Manufacturers.. do you think this is the problem? i am also using the CRC as the identifiers.. which i am following the template you have setup in OEMSCAN.ini ..

[color="Red"]here are a few screenshots[/color]:
Image

The names in red are descriptors only? or do they serve a purpose?
Image

[color="Red"]NOTE[/color]:
when i integrate with RVM .. there are no errors ..

[color="Red"]here is the RVM log[/color]:
Code: Select all
2010-04-01_22.21.43
Log Startup @ 22:21:43 local time, on April 01, 2010.

Running OS: WIN_VISTA  X64
RVMIntegrator v1.6

"D:\Users\RudeBoySes\Documents\RVM Integrator 1.6.1 Beta 2.1\RVM_Integrator_1.6.exe"

22:22:21  - English - Windows XP Professional x86 - Retail SP3 Found
22:22:36  - English - Windows XP Professional x86 - Retail SP3 Found
22:23:53  -
22:23:53  - Source Drive         = D:\Users\RudeBoySes\Documents\Windows XP\Windows XP Professional with Service Pack 3 (x86) Retail CD (English)\Extracted
22:23:53  - Destination Drive    = D:\Users\RudeBoySes\Documents\Windows XP\WINDOWS.XP.PRO.SP3.32-BIT.(X86).MULTI.OEM.DVD
22:23:53  - Destination Size     = 826.16 GB
22:23:53  - Working Directory    = D:\Users\RudeBoySes\Documents\Windows XP\WINDOWS.XP.PRO.SP3.32-BIT.(X86).MULTI.OEM.DVD\I386
22:23:53  - Temp Directory       = D:\Users\RudeBoySes\Documents\Windows XP\WINDOWS.XP.PRO.SP3.32-BIT.(X86).MULTI.OEM.DVD\I386\rvmtemp
22:23:53  -
22:23:53  - Starting Integration
22:23:53  -
22:23:53  - Copying Files To The Destination Directory.
22:23:53  -   Copying Working Directory...
22:26:26  - 6950  Files Copied in 152 Seconds
22:26:26  -
22:26:26  - Checking Destination For OS Type.
22:26:26  - English - Windows XP Professional x86 - Retail SP3 Found
22:26:26  -
22:26:26  - Extracting OEMSCAN_1.4.1_MR_SMARTEPANTS_ADDON_MULTIOEM_1.8x.7z
22:28:50  -     MD5 Hash = 2753980ac885d3be9afa8b0ba29d225a
22:28:50  - Clearing any Read Only Attributes.
22:29:02  -
22:29:03  - Gathering temp files
22:29:03  - Processing new .CAT files found in SVCPACK
22:29:04  -
22:29:04  - Shifting Stuff Around
22:29:40  - 595  Files Moved in 35 Seconds
22:29:40  - Analyzing 1 Entry Files
22:29:40  - Processing OEMSCAN 1.4.1 Addon for multi-system installs v1.8.2/mr_smartepants   Build Date: 2009/12/16
22:29:41  -     Gathering [DirMove] Entries
22:29:41  -
22:29:41  - Preparing System Files...
22:29:41  -   sysoc.inf
22:29:41  -   svcpack.inf
22:29:41  -   dosnet.inf
22:29:41  -   txtsetup.sif
22:29:52  -
22:29:52  - Processing Sysoc.inf
22:29:52  - Processing svcpack.inf
22:29:52  - Processing dosnet.inf
22:29:53  - Processing txtsetup.sif
22:29:57  -
22:29:57  -       Compressing Files ASMS...
22:30:05  -
22:30:05  - Processing [EditFile]
22:30:05  -
22:30:05  - Moving Files Found In OEMSCAN 1.4.1 Addon for multi-system installs
22:30:05  - Moving Directories
22:32:38  - Entire .ini Processing Completed in 177 Seconds
22:32:38  -
22:32:38  - Compressing and Moving Edited Files
22:32:38  - Cleaning Up.
22:32:40  - Integration Completed.
22:32:40  - Total Integration Time = 373 Seconds
22:32:40  - ==================================================================================
22:32:40  -


i would really appreciate it if you can spare a few minutes of your precious time to take a look through my post .. any suggestion is welcome :)

[color="Blue"]P.S.[/color]
[color="Red"]*[/color] i have the OEMBIOS files in: FILESETS > XP
[color="Red"]*[/color] i have the Keys in: Keys > XP > XP_Pro > OEMSCAN.ini
[color="Red"]*[/color] I am using Genuine, Untouched XP PRO SP3 32-Bit Retail
[color="Red"]*[/color] I also used RVM for integration & ISO Compiling .. all finished without any errors
RudeBoySes
Junior Member

Posts: 8
Users Information
Joined: Wed Mar 31, 2010 12:59 pm

Postby mr_smartepants » Fri Apr 02, 2010 5:16 am

RudeBoySes wrote:22:22:21 - English - Windows XP Professional x86 - Retail SP3 Found
[color="Red"]*[/color] I am using Genuine, Untouched XP PRO SP3 32-Bit Retail


That's your problem. This addon is for OEM versions only, NOT retail.
Not all heroes wear capes, some wear Kevlar! OEMSCAN pre-activation addon for OEM XP & 2003
mr_smartepants
Senior Member

Posts: 536
Users Information
Joined: Fri Feb 02, 2007 11:06 pm

Postby RudeBoySes » Fri Apr 02, 2010 7:54 am

mr_smartepants wrote:That's your problem. This addon is for OEM versions only, NOT retail.


i am using "Retail" version but using your "addon" to make it OEM ?

EDIT:
N/M :) i think i understand what you are saying :) i took a look through my Single OEM Discs and found the differences ..
RudeBoySes
Junior Member

Posts: 8
Users Information
Joined: Wed Mar 31, 2010 12:59 pm

Thank You all...

Postby humble3d » Sat Apr 17, 2010 1:18 am

Thank you all so very much...
I don't know if I can learn all this but,
Might as well try...
Many Thanks :)
humble3d
Junior Member

Posts: 1
Users Information
Joined: Fri Apr 16, 2010 11:42 pm

PreviousNext

Return to The OEM A.C.T.

Who is online

Users browsing this forum: No registered users and 2 guests

cron